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The Finder app is arguably the most central element of the OS X user experience. 
It lies at the very heart of nearly everything you do. In light of this, you should 
learn to make the most of it! Follow along as we go over ten awesome tips for 
improving your Finder use. We’ll cover everything from adding tabs to hidden 
shortcuts.

1. Add Tabs
The single most important feature for managing your Finder windows is tabs. 
There’s a little problem with this though: Finder doesn’t have tabs. If you’re waiting 
for a fancy Terminal command to remedy the problem, you’re out of luck. The 
feature simply isn’t there.

The single most important feature for 
managing your Finder windows is tabs.

Nearly anyone can instantly see the benefit of having web-browser-like tabs for file navigation, 
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at least anyone but but the good folks at Apple. We’ve all been begging for this feature for 
years, but these pleas have fallen on deaf ears. Maybe they’re too busy trying to figure out what 
to do with Ping.
Having tabs in a Finder window just makes good sense doesn’t it? Who among us hasn’t found 
ourselves juggling three Finder windows while wishing there were a better way to organize 
them?
The good news is that in lieu of a solution from Apple, there are two really solid third party 
methods for achieving true enlightenment through tabbed browsing.

TotalFinder
TotalFinder is hands down the most seamless way to implement tabs in Finder. The best (and 
perhaps worst) part about TotalFinder is that it actually replaces your current Finder app (in 
functionality only, not literally).
TotalFinder is hands down the most seamless way to 
implement tabs in Finder.
What this means is that your Finder will be exactly where it’s always been. All your shortcuts 
and normal methods will work perfectly, the main difference is that you’ll now have tabs! These 
tabs look, feel and act just like those found in Chrome, so you’ll feel right at home using them.

TotalFinder
The implementation here sounds scary, but it’s actually quite well done. In truth, your original 
Finder application is left 100% intact and you can always return to it by restarting the Finder. 
That means in the event that TotalFinder bugs out or stops working (I’ve used it for years with 
no issues), you can quickly revert to the old school Finder that you know and love.
TotalFinder throws in a few more optional tweaks and additional settings as well, but the tab 
functionality is really the main feature.

http://totalfinder.binaryage.com/


Path Finder
Unlike TotalFinder, which seeks to replace Finder and largely keep it unchanged aside from the 
tabs, Path Finder is really a completely separate file browser. It looks and acts a lot like Finder, 
but with a ton of added functionality.

Path Finder 6
Tabs, split views, additional sidebars, tags, batch renaming; you name it, Path Finder has it. If 
you’re just looking for tabbed Finder windows, go with TotalFinder. If you’re looking for a 
completely revamped file browsing experience, Path Finder is your app.
Also, since it’s a standalone app that’s completely separate from Finder, there’s no worry about 
it feeling hacky.

http://cocoatech.com/pathfinder/


2. Use Labels Selectively
Labels are a Finder feature that many users never even touch. Once you do begin 
experimenting them, it’s easy to go overboard and label everything, which can 
make for an ugly, cluttered experience that will probably have you back to running 
label free in a week.

Overuse of labels kills their effectiveness
The trick to using labels is to do it intentionally and selectively. First, decide on 
your own mental meanings for a few different colors. For instance, if you’re a 
designer, you might label folders for current projects green and those for past 
projects gray.
The trick to using labels is to do it intentionally and 
selectively.



Once you’ve got a few colors figured out, then it’s time to consider how you want 
to use labels. It’s far too work intensive to apply and maintain different statuses for 
every file, so you should decide on a few scenarios where they will be genuinely 
helpful.

Your eyes should shoot straight to the labelled item.
For instance, I often use labels to draw attention to a single folder or file. If I have 
a large group of folders in the same directory but find myself continually referring 
to one above the others, I’ll apply a quick label to make that folder stand out from 
the rest. This saves me a second or so of browsing each time I want to use that 
folder because it’s so clearly differentiated.
Ultimately, my advice is to construct your own simple system for using labels and 
set a goal of two weeks for the trial run. After that, you can decide whether it’s 
something that has really helped or simply added extra work to your file browsing 
experience.



3. Use an Efficient Layout
Finder has lots of different ways to view files, almost none of which are 
necessarily bad, they’re just good for different things. Which layout is “best” 
depends entirely upon the specific browsing scenario and its worth the time to 
think through which is ideal for certain tasks.
The tip here is to let go of your tendency to choose a 
layout and stick with it.
For example, let’s say you’re browsing for something that’s fairly deep into a 
folder hierarchy, meaning that instead of merely sitting on your desktop, it’s 
nestled a good 5-10 folders in.
In this scenario, the column view mode is going to be your best bet because it 
allows you to quickly jump through several directories. Like the list view, it’s easy 
to browse and it reduces your effort by opening folders with single clicks rather 
than double clicks.

Column View is awesome for deep browsing
For the purpose we just outlined, an icon view would’ve been a horrible way to go. 
However, when I’m browsing through and editing a folder full of images, the icon 
view is much better suited for my workflow. The grid layout maximizes space 
efficiency and I can change the icon size to be nice and large for easy previewing.



Icon view is perfect for previewing images.
The tip here is to let go of your tendency to choose a layout and stick with it. Make 
sure you constantly evolve to the situation and take advantage of each view 
mode.



4. Sorting is Awesome
Sorting in Finder has been around for ages, but in the last few versions of OS X, it 
has really come into its prime with improved appearance of sorted folders.
If you haven’t tried sorting in a while, it’s time to take 
another look.
If you haven’t tried sorting in a while, it’s time to take another look. In many of the 
sorting modes, Apple has added categorizations and clear visual distinctions. For 
instance, when you sort by modified date, it used to be that the files simply lined 
up differently, but now they form clusters based on when they were last modified.

Sorted folders are really nicely organized.
As you can see, each cluster has some extra padding and a little header that tells 
you what’s going on here. Similarly, if you choose to sort by file type, you’ll see 
headers and clusters for each of the file types contained in that cluster.



Name Smart
By default, the sorting method for most folders is “none.” However, Finder is still 
depending on a basic alphabetical presentation of the files. This can get a little 
strange in some cases if you want your folders presented in a very specific order 
that doesn’t naturally mesh with the alphabetical or other sorting algorithms.
Always remember that you can pretty easily manipulate 
the alphabetical order if you name your folders with 
numbers.
Always remember that you can pretty easily manipulate the alphabetical order if 
you name your folders with numbers. For instance, my work folders are separated 
by month. I have folders named Jan, Feb, Mar, Apr, May, etc. This helps me keep 
all of my projects organized.
Unfortunately, this naming convention wreaks havoc on the sort order (Apr comes 
before Jan), and using the modified or created sort methods don’t help since I’m 
usually popping around from project to project.

Name with numbers to manipulate the order



The solution is simple, I begin the folder names with numbers that correspond to 
the order of the months: 1-Jan, 2-Feb, 3-Mar. Think about ways that you can 
manipulate the sort order of your folders to your benefit.

5. Set a Default Folder
This is such a simple trick that saves you a ton of time, and yet I honestly never 
even thought to do it until recently, and I’ve been on a Mac since OS 9.
Basically, the general idea is that I work on my Mac all day every day, which 
means that when I open a Finder window, odds are I’m going to be navigating to 
my “Work” folder. I always keep this in my sidebar, but even then it’s a whole click 
away every single time. Setting up a default folder though makes it so that that I’m 
already in my work folder whenever I launch a new window. Simple, but extremely 
convenient.



Sorted folders are really nicely organized.
To set up a default folder, for to Finder>Preferences and change the “New Finder 
windows show” drop down menu to whatever folder you’d like to use. If it isn’t 
shown by default, hit the “Other…” item on the bottom.

Default Folder X
Sure, setting a default folder in Finder preferences is handy, but if you really want 
to speed up your workflow, you should check out Default Folder X.

http://www.stclairsoft.com/DefaultFolderX/


Default Folder X
This app dramatically improves the functionality of your open and save dialogs in 
OS X. You can use it to set a unique default folder for every single application. 
There are also all of these extra panels that pop up around a dialog that let you 
quickly access favorite and recently used folders as well as search tags and 
breeze quickly through a folder hierarchy.
This app dramatically improves the functionality of your 
open and save dialogs in OS X.
I always say that this is one utility that you have no idea you need until you try it. 
Use it for a week and you won’t be able to get by without it.



6. Show the Path & Status Bars
Starting with Lion, Apple decided to simplify the look of Finder and strip out some 
of the clutter that they added in Snow Leopard. This is all well and good, but I 
actually used those features that they decided to turn off! Namely the Status Bar 
(shows free space, number of items in a folder, etc.) and the ability to see and 
interact with a file path.

The stripped Finder view
Fortunately, these features are still around, and they’re only a click away if you 
know where to look. To bring back the Status Bar, go to View>Status Bar in the 
Finder menu. This also brings back that little icon size slider that’s so useful. 
Similarly, to bring back the Path Bar, go to View>Path Bar.

With the Path and Status Bars turned on

7. Customize Your Toolbar
While you’re messing around in the Finder View menu, you should also take a 
look at the various options available for customizing your toolbar in 
View>Customize Toolbar.



Customizing the toolbar
Here you’ll find several extra buttons that you can simply drag into your toolbar for 
quick access. Virtually all of these features (Get Info, Delete, New Folder, etc.) 
can be accessed via keyboard shortcuts but if you’re a new user you might find 
the buttons useful.

Toss in Anything You Want
Here’s a great tip that you may not know about, outside of the Customize Toolbar 
dialog, you can still drag items to your toolbar. This works for pretty much 
anything: files, folders, even apps!



Did you know that you can put apps in your toolbar?
To do this, simply click and drag on an item that you want quick access to, and 
drop it right next to the search bar (on the left). This only works in this location, 
you can’t drag items to other parts of the window (apart from the sidebar of 
course).

8. Use Smart Folders
We’ve got an entire article coming up dedicated to Smart Folders so I won’t spend 
too much space on this, but you should know that Smart Folders are a stellar way 
to save time in Finder.
Smart Folders are a stellar way to save time in Finder.
Smart Folders are essentially saved Spotlight searches that can help you access 
the same information set again and again. For instance, if you set up a search to 
monitor any files that you’ve modified in the last seven days in your work folder, 
you can save that as a Smart Folder and throw it in your sidebar.



A Smart Folder in Action
This gives you a constantly updating folder that shows you what you’ve been 
working on recently. You can do this for browsing history, photos; anything you 
want.

9. Reacquaint Yourself with 
Quick Look
Quick Look has become such an integral part of the OS X experience that you 
likely use it all the time without even thinking about it. Select a file, hit space, and 
take a look. It’s so easy and convenient!



The thing that’s easy to forget is that Quick Look has some other really great 
features as well. For example, try selecting a bunch of images, then hit space bar. 
From here, there’s a grid icon at the top left that will spread all of the images 
apart. Even better, hit the fullscreen icon at the top right and you’ll be taken into 
an interactive slideshow without ever opening a single app!

Quick Look is great for looking at lots of files at once.
There are a couple of other ways to launch fullscreen mode as well. Try holding 
down Option while launching Quick Look to be taken right into a fullscreen 
preview. Alternatively, you can perform a pinch out gesture on your trackpad when 
viewing a file in Quick Look to see it in fullscreen.

Quick Look Plugins
To expand the functionality of Quick Look, be sure to check out a list of available 
plugins. These are great for adding previews for non-supported file types. The 
unfortunate part is that the good Quick Look plugins are almost all years old and 
not actively being developed, updated or distributed.

http://www.qlplugins.com/
http://www.qlplugins.com/
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10. Know Your Shortcuts
If you really want to be a master of Finder, you should make it a point to memorize 
the most helpful keyboard shortcuts. There are a ton of these, too many to list 
exhaustively here (check the File menu for the obvious ones). However, I will 
share some of my favorites below:

Several folders can be accessed quickly via a shortcut. For instance, 
Command-Shift-U will take you to your Utilities folder and Command-
Shift-A will launch your Applications folder. Also try Command-Shift-D for 
the Desktop, or just Command-D if you’re in an Open/Save dialog.

Command-T adds the selected item to your sidebar.

Command and 1, 2, 3, or 4 changes your view mode.

To have Finder intelligently merge the contents of two identically named 
folders, Option-Drag one into the same directory as the other. This will 
reveal the standard “Replace” dialog with a new option, “Merge”.

Command-Option-W or Option-Click the close button to close all Finder 
windows at once.

When dragging a file to a new directory, you can hold it over a folder for a 
second to pop open that folder and proceed deeper into the hierarchy. To 
speed up this process, hit Space each time you come to a folder.

Hold Option while browsing the Finder menu options to review hidden 
items.

Use Command-Up and Command-Down to move through directories.

Use the Left and Right arrows to collapse and expand folders in list view.

Command-[ and Command-] move to the previous/next folder.
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The hidden powers of 
Mountain Lion's Preview

http://www.macworld.com/article/2010521/the-hidden-powers-of-mountain-lions-
preview.html

Preview is Apple’s top-secret tool for viewing and manipulating PDF 
files, graphics, and more. The secret, however, isn’t that it exists (look 
in your Applications folder) but that this seemly simple program 
harbors tons of advanced features. You can use Preview to annotate 
PDFs, delete or rearrange PDF pages, crop images, and more. Here’s 
an overview of the recent additions to Preview that you may not know 
about.

Take a closer look
When you’re viewing a simple PDF—just a page or two—it’s easy to 
scroll to see the content you need. But if you have a long document, 
it’s more efficient to jump to the section you want instead of scrolling 
through dozens of pages. You can do that and more by clicking the 
View button to the left of Preview’s toolbar. Here you’ll see a pop-up 
menu listing these options:

•
• Your viewing options.
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Content Only shows the pages of your PDF without displaying the 
sidebar. This is the default display. It’s great when you need an 

uncluttered view of your document or image.
• Thumbnails displays the sidebar, and in it, small thumbnail images 

of the pages of your PDF, or your collection of images. You can 
scroll through the sidebar quickly to find the page you want to 
see, and then click it to jump to that page. For most uses, you’ll 
find that the Thumbnails view works best.

• Table Of Contents displays text links for the PDF’s table of 
contents. If you’re reviewing a long document with a table of 
contents, this view can save you a lot of time hunting for material.

• Highlights And Notes lists any highlights or annotations you have 
made. Click one to read it. See below for more about annotating 
PDFs.

• Contact Sheet shows page thumbnails across the content section 
of Preview’s window. This is especially useful when you’re looking 
at a collection of images with Preview.

Note that the View menu also allows you to choose how Preview 
displays pages:

• Continuous Scroll lets you scroll through a document while seeing 
page breaks.

• Single Page shows only one page at a time.
• Two Pages shows left and right pages together, so you can see 

layouts that stretch across a spread, say in a brochure or 
magazine.

Delete or rearrange PDF pages
If you’re in Thumbnails view, you can easily delete or move pages 
within a PDF. To delete a page, click a thumbnail, and then press 
Delete. Save the document, and that page disappears.

To move a page, just click a thumbnail and drag it to the location in the 
sidebar where you want it to be. Save the document, and the page will 
take its new position.



Crop images
To crop an image in Preview, open the file and then choose Tools -> 
Rectangular Selection, if that isn't already checked. Hover your pointer 
over the file, and you’ll see a crosshair cursor. Click and drag this 
cursor around the area to crop. When you stop, you’ll see a marquee 
selection, which you can adjust from the sides and corners. When you 
have the exact crop you want, select Tools -> Crop (or press 
Command-K), and then save the file.

Check Preview's Tools menu to find a basic image-cropping tool. You can see the marquee 
selection around the iTunes Player window at the bottom of this image.



Try PDF annotation tricks
I wrote about annotating PDFs about a year ago, but Mountain Lion 
has made some interesting changes to this essential Preview feature. 
For instance, consider notes, perhaps the most commonly used 
annotation. To leave a note about something in a PDF, choose Tools -> 
Annotate -> Note. (Or reveal the Edit toolbar by selecting View -> 
Show Edit Toolbar, and then click the Note button.) Your cursor turns 
into a crosshair. Click where you want to write your note, and then type 
in the yellow box that appears.

Reveal the text of notes and annotations in the sidebar by selecting View -> Highlights And 
Notes.

The text of each note is hidden after you finish writing. Click any note 
(indicated by a yellow square on the PDF) to expand it and see your 
text in context again. You can also reveal note text by displaying the 

http://www.macworld.com/article/1162946/how_to_annotate_pdfs.html


sidebar and choosing Highlights And Notes from the View menu on the 
toolbar. Instead of scrolling through a document to see notes, you can 
click a note in the sidebar, and Preview hops to that page.

You can also search your notes and highlights. Make sure the 
Highlights And Notes sidebar is visible, and then use Preview’s search 
field to search for a string of text. The search will show results in that 
sidebar; if you want to go to the location of a hit, just click it. (If that 
sidebar is not visible, the search function will search only in your PDF’s 
content.)

Depending on what you need to do with PDFs or images in Preview, 
it’s worthwhile to explore the other tools in the Tools -> Annotate menu 
and on the Edit toolbar. Highlight Text (Command-Control-H) and 
Strike Through Text (Command-Control-S) can be particularly useful.

Sign a PDF
When you receive a PDF document by email from your bank, your 
school, or some other organization, it can be a puzzle to determine the 
best way to sign the file and return it to the sender. Before, you had to 
print out the document, sign it, scan it, and then send it. Now, you can 
save your signature and add it to any PDF.

To do this, choose Preview -> Preferences, click Signatures, and then 
click the plus sign (+) to create a signature. A Signature Capture 
window will appear, telling you to sign your name in black ink on white 
paper and then hold it up in front of your Mac’s camera. Preview will 
flip the signature around so that it’s in the right direction, and then, 
when you click Accept, will save it. You can see your signature in the 
Signature preferences, and if you need more than one signature—say, 
for your spouse or children—you can add more signatures.



This is what the Signature Capture window looks like when you hold a piece of paper with your 
signature in front of your Mac's camera.

When you want to sign a PDF, go to the page where you need to add 
your signature, click the Annotate button on the toolbar (if the Edit 
toolbar is not visible), and then click the Signature pop-up (which looks 
like an S with a line underneath) in the Edit toolbar. Choose your 
signature. (To see this procedure in action, check out this video by Dan 
Frakes.)

One tip: Write your signature very large, with a marker or a very dark 
pen, so that it shows up better. When Preview shrinks the signature, it 
will still display correctly. If you use a standard ballpoint pen, the 
resulting signature may be too light.

Fill out and create PDF forms
If you’ve received applications or other documents in PDF, you’ve most 
likely encountered PDF forms, which allow you to type right into the 
fields and then print out (or send) a neat and legible copy. To fill out a 
PDF form, just click on any of its lines, and type. Preview notices small 
squares and treats them as checkboxes; simply click in one to check 
it.

In the past, creating a PDF form was possible only with expensive 
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software such as Adobe Acrobat. Now, however, you can create a form 
in any text program, such as Microsoft Word or Apple Pages, and 
anyone with Mountain Lion’s Preview can fill it out. You can’t share 
these forms with people who don't use Preview on Mountain Lion; 
such forms don’t work with Acrobat Reader, for instance.

It's easy to make a PDF form that anyone can fill out using Mountain Lion's Preview.

Here’s an example: I made the document here with Pages, using text 
objects to create the small squares and large rectangle, and 
underlining to make the lines.

Keep PDFs accessible in the cloud
Finally, Mountain Lion brings iCloud storage to a number of 
applications, including Preview. If you open a PDF in Preview and want 
to save it to the cloud, choose File -> Move To, and then, from the 
Where menu, choose iCloud. You’ll have access to this PDF on other 
Macs that share the same iCloud account, but unfortunately you won’t 
be able to view it on an iOS device.

With all of these features, getting to know Preview a bit better is worth 
the effort. It’s a powerful tool, not just for viewing PDFs and graphics 
but also for editing and annotating PDFs.
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